Storage Issue for Hosting
Incident Report for Beyond Hosting
Resolved
Resolved. Please see your email for updates.
Posted Mar 09, 2018 - 03:04 EST
Identified
Currently investigating a storage outage for Hosting Customers.
Posted Mar 08, 2018 - 16:06 EST