Multiple Large DDOS Attacks
Incident Report for Beyond Hosting
Resolved
No issues reported overnight.
Posted Mar 04, 2018 - 12:43 EST
Update
You can read more about how attackers are using this global vulnerability here: http://www.zdnet.com/article/memcached-ddos-the-biggest-baddest-denial-of-service-attacker-yet/
Posted Mar 03, 2018 - 21:28 EST
Identified
Our Network is currently the target of several large DDOS attacks. We are working on mitigating these the best we can. The current Memcache vulnerability is enabling attackers to massively impact the internet with huge attacks greater than 1TBPS.

We are doing our best to protect our customers from these high volume attacks and will update this page as updates become available.
Posted Mar 03, 2018 - 21:26 EST